Довідник з лабораторных робіт з "Чисельних Методів"

Довідник для лабораторних робіт з "Чисельних Методів"

Розробники: Галина Ернестівна Копча-Горячкіна
Лозовий Олег Сергійович

Лабораторна робота №1 : Знаходження абсолютної та відносної похибок обчислень
Лабораторна робота №2 : Алгебра матриць
Лабораторна робота №3 : Розв'язування систем алгебраїчних рівнянь методом Гауса
Лабораторна робота №4 : Розв'язування систем лінійних алгебраїчних рівнянь за формулами Крамера
Лабораторна робота №5 : Обчислення значень елементарних функцій
Лабораторна робота №6 : Відокремлення коренів нелинійних рівнянь
Лабораторна робота №7 : Уточнення коренів нелинійного рівняння методом дотичних
Лабораторна робота №8 : Уточнення коренів нелинійного рівняння методом хорд
Лабораторна робота №9 : Розв'язування нелінійних рівнянь комбінованим методом хорд та дотичних
Лабораторна робота №10 : Обчислення визначених інтегралів за формулами прямокутників
Лабораторна робота №11 : Обчислення визначених інтегралів за формулою трапецій та Сімпсона


Лабораторна робота 1 : Знаходження абсолютної та відносної похибок обчислень

Завдання: Обчислити відносну та обсолютну похибку обчислень

Приклад 1

; де m = 28.3(+/-0.02), n = 7.45(+/-0.01), k = 0.678(+/-0.003);

Розв'язання:

Знаходимо m2=800.9; n3=413.5; [image] =0.8234;

Далі, маємо δm=0.02/28.3=0.00071; δn=0.01/7.45=0.00135;
δk=0.003/0.678=0.00443, звідси
δx=2δm+3δn+0.5δk=0.00142+0.00405+0.00222=0.00769=0.77%

αx=4.02*105(+/-3.1*103.
Відповідь: X=4.02*105(+/-3.1*103); δx=0.77%.

Приклад 2

; де n = 3.0567(+/-0.0001), m = 5.72(+/-0.02);

Розв'язання:

Маємо n-1=2.0567(+/-0.0001);
m+n=3.057(+/-0.0004)+5.72(+/-0.02)=8.777(+/-0.0204);
m-n=5.72(+/-0.02)-3.057(+/-0.0004)=2.663(+/-0.0204);
;

=0.00238+0.01532=0.0177=1.77%
αn=2.55*0.0177=0.046.
Відповідь: N≈2.55(+/-0.046); δN=1.77%.
Варіанти завдань до лабораторної роботи
До списку лабораторных робіт


Лабораторна робота 1:Варіанти

Завдання: Обчислити відносну та обсолютну похибку обчислень

Варіант 1

Варіант 2

Варіант 3

Варіант 4

Варіант 5

Варіант 6

Варіант 7

Варіант 8

Варіант 9

Варіант 10

Повернутись до прикладу
До списку лабораторных робіт


Лабораторна робота №2 : Алгебра матриць

Завдання 1: Провести задані операції над матрицями

Приклад

Розв'язання:

Спочатку обрахуємо матриці 3А+В та 2А+В. Потім помножимо дві матриці що вийшли між собою.

Завдання 2: Обчислити детермінант матриці

Приклад

Розв'язання:

Розв'язок проводимо у таблиці

Δ = 0.32*(-0.5375)*3.84184*1.02358= -0.676378.

Відповідь:Δ ≈-0,6764

Завдання 3:Знайти обернену до даної матриці

Приклад

Розв'язання:

Розв'язок проводимо в таблиці

Відповідь:
Варіанти до лабораторної роботи 2
До списку лабораторних робіт


Лабораторна робота №2 : Варіанти

Завдання 1: Провести задані операції над матрицями

Завдання 2: Обчислити детермінант матриці

Завдання 3: Знайти обернену до даної матриці

Завдання 4: Знайти транспоновану матрицю до оберненої з завдання 3

Варіант 1

1)
2)
3)

Варіант 2

1)
2)
3)

Варіант 3

1)
2)
3)

Варіант 4

1)
2)
3)

Варіант 5

1)
2)
3)

Варіант 6

1)
2)
3)

Варіант 7

1)
2)
3)

Варіант 8

1)
2)
3)

Варіант 9

1)
2)
3)

Варіант 10

1)
2)
3)

Варіант 11

1)
2)
3)

Варіант 12

1)
2)
3)

Варіант 13

1)
2)
3)

Варіант 14

1)
2)
3)

Варіант 15

1)
2)
3)

Варіант 16

1)
2)
3)

Варіант 17

1)
2)
3)

Варіант 18

1)
2)
3)

Варіант 19

1)
2)
3)

Варіант 20

1)
2)
3)

Варіант 21

1)
2)
3)

Варіант 22

1)
2)
3)

Варіант 23

1)
2)
3)

Варіант 24

1)
2)
3)

Варіант 25

1)
2)
3)

Варіант 26

1)
2)
3)

Варіант 27

1)
2)
3)

Варіант 28

1)
2)
3)

Варіант 29

1)
2)
3)

Варіант 30

1)
2)
3)
Лабораторна робота 2
До списку лабораторних робіт


Лабораторна робота 3 : Розв'язування систем алгебраїчних рівнянь методом Гауса

Приклад

Розв'язання:

Розв'язок проводимо у таблиці

Відповідь:x1=2.826; x2=-0.334; x3=-2.711;x 4=-0.669;
Варіанти завдань до лабораторної роботи 3
До списку лабораторных робіт


Лабораторна робота 3 : Варіанти

Розв'язати систему алгебраїчних рівнянь методом Гауса

Варіант 1

Варіант 2

Варіант 3

Варіант 4

Варіант 5

Варіант 6

Варіант 7

Варіант 8

Варіант 9

Варіант 10

Варіант 11

Варіант 12

Варіант 13

Варіант 14

Варіант 15

Варіант 16

Варіант 17

Варіант 18

Варіант 19

Варіант 20

Варіант 21

Варіант 22

Варіант 23

Варіант 24

Варіант 25

Варіант 26

Варіант 27

Варіант 28

Варіант 29

Варіант 30

 Повернутись до прикладу
До списку лабораторних робіт


Лабораторна робота №4 : Розв'язування систем лінійних алгебраїчних рівнянь за формулами Крамера

Приклад

Розв'язання

Виконайте перевірку. Для перевірки підставте всі значення в рівняння та обрахуйте чи співпадае результат.
 Відповідь:x1=2; x2=3; x3=-1;x 4=4;
Варіанти до лаболаторної роботи 4
До списку лабораторных робіт


Лабораторна робота №4 : Варіанти

Розв'язати систему лінійних алгебраїчних рівнянь за формулами Крамера. Виконати перевірку до всіх завдань.

Варіант 1

1)
2)
3)

Варіант 2

1)
2)
3)

Варіант 3

1)
2)
3)

Варіант 4

1)
2)
3)

Варіант 5

1)
2)
3)

Варіант 6

1)
2)
3)

Варіант 7

1)
2)
3)

Варіант 8

1)
2)
3)

Варіант 9

1)
2)
3)

Варіант 10

1)
2)
3)

Варіант 11

1)
2)
3)

Варіант 12

1)
2)
3)

Варіант 13

1)
2)
3)

Варіант 14

1)
2)
3)

Варіант 15

1)
2)
3)

Варіант 16

1)
2)
3)

Варіант 17

1)
2)
3)

Варіант 18

1)
2)
3)

Варіант 19

1)
2)
3)

Варіант 20

1)
2)
3)

Варіант 21

1)
2)
3)

Варіант 22

1)
2)
3)

Варіант 23

1)
2)
3)

Варіант 24

1)
2)
3)

Варіант 25

1)
2)
3)

Варіант 26

1)
2)
3)

Варіант 27

1)
2)
3)

Варіант 28

1)
2)
3)

Варіант 29

1)
2)
3)

Варіант 30

1)
2)
3)
До прикладу лабораторної роботи 4
До списку лабораторних робіт


Лабораторна робота 5 : Обчислення значень елементарних функцій

Завдання 1

Використовуючи схему Горнера, скласти таблицю значень многочлену на відрізку [0,5;2,0]; з кроком h=0,25. Обрахунки робити з точністю до 0,0001, відповідь округлити до тисячних(0,001)

P(x)=0,883x5 - 1,217x4 + 1,452x3 + 0,572x2 -2,343x +1,158

Для обрахунків за схемою Горнера cкладемо таблицю, яка містить всі проміжкові результати та значення шуканого многочлену

В верхньому рядку таблиці запишемо коофіцієнт ai даного многочлена, в першому рядку - значення аргументу х. Інші рядки містять значення bi які в таблиці Горнера обраховуються за формулою:

В останньому стовбчику таблиці одержуемо значення многочлену P(x).Округлюємо їх до 0,001 да одержуемо відповідь

xi | P(xi)
0,5 | 0,263
0,75 | 0,160
1,00 | 0,505
1,25 | 2,373
1,50 | 4,375
1,50 | 4,375
1,75 | 9,670
2,00 | 19,160

Завдання 2

Обчислити значення функцій при заданих значеннях аргумента методом розкладу в ряд з точністью до 10-6

1) Використаємо розклад

Обрахунок окремих доданків продовжуємо доти, поки не буде виконана нерівність
Складемо таблицю значень окремих доданків.
a) x=0.826

Шукане значення являє собою наступну суму:

б) х=2,417

2) Використаємо рівність

Значення доданків занесемо в таблицю

3)Використаємо рівності

Складемо таблицю значень доданків вигляду ui та vi.
a)x=0,476

З таблиці одержуємо
Для перевірки додамо sin2+cos2. Якщо одержимо в результаті не 1, то допущено помилку.

Приблизно дорівнює, тому можна сказати, що розв'язок вірний.
б) х=0,684

Варіанти завдань до лабораторної роботи 5
До списку лабораторных робіт


Лабораторна робота №5 : Варіанти

Завдання 1 до всіх варіантів.

Використовуючи схему Горнера, скласти таблицю значень многочлену на відрізку [0,5;2,0]; з кроком h=0,25. Обрахунки робити з точністю до 0,0001, відповідь округлити до тисячних(0,001)

Завдання 2 до всіх варіантів.

Обчислити значення функцій при заданих значеннях аргумента методом розкладу в ряд з точністью до 10-6

n це номер варіанту.

Варіант 1

Варіант 2

Варіант 3

Варіант 4

Варіант 5

Варіант 6

Варіант 7

Варіант 8

Варіант 9

Варіант 10

Варіант 11

Варіант 12

Варіант 13

Варіант 14

Варіант 15

Варіант 16

Варіант 17

Варіант 18

Варіант 19

Варіант 20

Варіант 21

Варіант 22

Варіант 23

Варіант 24

Варіант 25

Варіант 26

Варіант 27

Варіант 28

Варіант 29

Варіант 30

 До завдань лабораторної роботи 5
До списку лабораторних робіт


Лабораторна робота 6 : Відокремлення коренів нелінійних рівнянь

Завдання 1: Відокремити корені рівняння графічно

tg(0,55x+0,1)=x2

Для того, щоб відокремити корені рівняння графічно, для початку нам необхідно побудувати графіки функцій y1=tg(0,55x+0,1) та y2=x2. Спочатку побудуємо таблицю значень цих функцій

Таким чином, корінь рівняння знаходиться на відрізку [0,6;0,8].

Відповідь: корінь рівняння знаходиться на відрізку [0,6;0,8].

Завдання 2: Відокремити корені рівняння аналітично

x3-0,2x2+0,5x+1,5=0.

Відокремимо корені рівняння аналітично. Для цого знайдемо
f=x3-0,2x2+0,5x+1,5;
f `=3x2-0,4x+0,5;
D=0,16-6<0.

Складемо таблицю знаків функції

Рівняння має один додатній корень, який належить в відрізку [-1,0].

Відповідь: корінь рівняння належить в відрізку [-1,0].
 Варіанти завдань до лабораторної роботи 6
До списку лабораторных робіт


Лабораторна робота 6 : Варіанти

 Лабораторна робота 6 : Відокремлення коренів нелінійних рівнянь

Завдання 1: Відокремити корені рівняння графічно

Завдання 2: Відокремити корені рівняння аналітично

Варіант 1

1)
2)

Варіант 2

1)
2)

Варіант 3

1)
2)

Варіант 4

1)
2)

Варіант 5

1)
2)

Варіант 6

1)
2)

Варіант 7

1)
2)

Варіант 8

1)
2)

Варіант 9

1)
2)

Варіант 10

1)
2)

Варіант 11

1)
2)

Варіант 12

1)
2)

Варіант 13

1)
2)

Варіант 14

1)
2)

Варіант 15

1)
2)

Варіант 16

1)
2)

Варіант 17

1)
2)

Варіант 18

1)
2)

Варіант 19

1)
2)

Варіант 20

1)
2)

Варіант 21

1)
2)

Варіант 22

1)
2)

Варіант 23

1)
2)

Варіант 24

1)
2)

Варіант 25

1)
2)

Варіант 26

1)
2)

Варіант 27

1)
2)

Варіант 28

1)
2)

Варіант 29

1)
2)

Варіант 30

1)
2)
До лабораторної роботи 6
До списку лабораторних робіт


Лабораторна робота №7 : Уточнення коренів нелінійного рівняння методом дотичних

Завдання 1: Відокремити корені рівняння графічно та уточнити один з них методом дотичних з точныстью до 0,001.

tg(0,55x+0,1)=x2

Для того, щоб відокремити корені рівняння графічно, для початку нам необхідно побудувати графіки функцій y1=tg(0,55x+0,1) та y2=x2. Спочатку побудуємо таблицю значень цих функцій

Таким чином, корінь рівняння знаходиться на відрізку [0,6;0,8]. Уточнюємо корінь методом дотичних. Оскільки f(0,6)>0; f(0,8)<0 та f ``(x)<0, то за початкове наближення візьмемо x0=0,8.

Обрахунки проводимо за формулою

Знайдемо

Побудуємо таблицю:

Відповідь: x≈0,750.

Завдання 2: Відокремити корені рівняння аналітично та уточнити один з них методом дотичних з точністью до 0,001.

x3-0,2x2+0,5x+1,5=0.

Відокремимо корені рівняння аналітично. Для цого знайдемо
f=x3-0,2x2+0,5x+1,5;
f `=3x2-0,4x+0,5;
D=0,16-6<0.

Складемо таблицю знаків функції

Рівняння має один додатній корінь, який належить відрізку [-1,0]. Уточнюємо корінь мотодом дотичних. Оскільки f(-1)<0, f(0)>0 та f ``(x)<0 то за початкове наближення беремо x0=-1.

Для обрахунків використовуємо формулу

Знаходимо f=x3-0,2x2+0,5x+1,5;
f `=3x2-0,4x+0,5;
Для обрахунків будуємо таблицю:

Відповідь: x≈-0,946.

Варіанти завдань до лабораторної роботи 7
До списку лабораторных робіт


Лабораторна робота №7 : Варіанти

Завдання 1: Відокремити корені рівняння графічно та уточнити один з них методом дотичних з точністью до 0,001.

Завдання 2: Відокремити корені рівняння аналітично та уточнити один з них методом дотичних з точністью до 0,001.

Варіант 1

1)
2)

Варіант 2

1)
2)

Варіант 3

1)
2)

Варіант 4

1)
2)

Варіант 5

1)
2)

Варіант 6

1)
2)

Варіант 7

1)
2)

Варіант 8

1)
2)

Варіант 9

1)
2)

Варіант 10

1)
2)

Варіант 11

1)
2)

Варіант 12

1)
2)

Варіант 13

1)
2)

Варіант 14

1)
2)

Варіант 15

1)
2)

Варіант 16

1)
2)

Варіант 17

1)
2)

Варіант 18

1)
2)

Варіант 19

1)
2)

Варіант 20

1)
2)

Варіант 21

1)
2)

Варіант 22

1)
2)

Варіант 23

1)
2)

Варіант 24

1)
2)

Варіант 25

1)
2)

Варіант 26

1)
2)

Варіант 27

1)
2)

Варіант 28

1)
2)

Варіант 29

1)
2)

Варіант 30

1)
2)
До лабораторної роботи 7
До списку лабораторних робіт


Лабораторна робота №7 : Уточнення коренів нелінійного рівняння методом хорд

Лабораторна робота №8 : Уточнення коренів нелінійного рівняння методом хорд

Завдання 1: Відокремити корені рівняння графічно та уточнити один з них методом хорд з точністю до 0,001

tg(0,55x+0,1)=x2

Для того, щоб відокремити корені рівняння графічно, для початку нам необхідно побудувати графіки функцій y1=tg(0,55x+0,1) та y2=x2. Спочатку побудуємо таблицю значень цих функцій

Таким чином, корінь рівняння знаходиться на відрізку [0,6;0,8].

Для того, щоб уточнити корінь методом хорд, визначимо знаки функції f`(x)=tg(0,55x+0,1)-x2 на кінцях проміжку [0,6;0,8] та знак другої похідної всередині відрізку

Для обрахунків використовуємо формулу

Обрахунки проводимо в таблиці

Відповідь: x=0,750

Завдання 2: Відокремити корені рівняння аналітично та уточнити один з них методом хорд з точністю до 0,001

x3-0,2x2+0,5x+1,5=0.

Відокремимо корені рівняння аналітично. Для цого знайдемо
f=x3-0,2x2+0,5x+1,5;
f `=3x2-0,4x+0,5;
D=0,16-6<0.

Складемо таблицю знаків функції

Рівняння має один додатній корінь, який належить відрізку [-1,0]. Щоб уточнити корінь, знаходимо другу похідну f ``(x)=6x-0,4; в проміжку [-1,0]. Ми бачимо, що виконується нерівність f ``(x)<0. Для обчислення використаємо формулу

Обрахунки робимо в таблиці:

Відповідь: x≈-0,946.
 Варіанти завдань до лабораторної роботи 8
До списку лабораторных робіт


Лабораторна робота №8 : Варіанти

 Лабораторна робота №8 : Уточнення коренів нелінійного рівняння методом хорд

Завдання 1: Відокремити корені рівняння графічно та уточнити один з них методом хорд з точністью до 0,001

Завдання 2: Відокремити корені рівняння аналітично та уточнити один з них методом хорд з точністью до 0,001

Варіант 1

1)
2)

Варіант 2

1)
2)

Варіант 3

1)
2)

Варіант 4

1)
2)

Варіант 5

1)
2)

Варіант 6

1)
2)

Варіант 7

1)
2)

Варіант 8

1)
2)

Варіант 9

1)
2)

Варіант 10

1)
2)

Варіант 11

1)
2)

Варіант 12

1)
2)

Варіант 13

1)
2)

Варіант 14

1)
2)

Варіант 15

1)
2)

Варіант 16

1)
2)

Варіант 17

1)
2)

Варіант 18

1)
2)

Варіант 19

1)
2)

Варіант 20

1)
2)

Варіант 21

1)
2)

Варіант 22

1)
2)

Варіант 23

1)
2)

Варіант 24

1)
2)

Варіант 25

1)
2)

Варіант 26

1)
2)

Варіант 27

1)
2)

Варіант 28

1)
2)

Варіант 29

1)
2)

Варіант 30

1)
2)
До лабораторної роботи 6
До списку лабораторних робіт


Лабораторна робота №9 : Розв'язування нелінійних рівнянь комбінованим методом хорд та дотичних

Завдання: Розв'язати рівняння третього степеня комбінованим методом хорд та дотичних, обрахувавши корені з точністью до 0,001.

Відділимо корені рівняння аналітично. Знаходимо

Побудуємо таблицю знаків функції f(x):

Рівняння має три дійсних кореня:x1∈(-∞,-2/3]; x2∈[-2/3,2];x3∈[2,+∞)

Зменшимо проміжки, що містять корені, до довжини рівній 1:
Отже, маємо три відрізки:
x1∈[-2;,-1];
x2∈[1,2];
x3∈[2,3]
Уточнимо корені на кожному з відрізків комбінованим методом.
1.x1∈[-2;,-1];
f(-2)<0;f(-1)>0;f ``(x)=6x-4. При -2 ≤х ≤-1 маємо f ``(х)<0. Для обрахунків використаємо формули:

де хn і хn - значення кореня з нестачею та надлишком. Припустимо, що х0=-2; х0=-1;
Всі обрахунки проведемо в таблиці, зазначивши, що:

Відповідь: x1≈-1,935.

2. x2∈[1,2];
f(1)>0;
f(2)<0;
f ``(x)>0 при 1≤x≤2. Для обрахунків використаємо формули
де хn і хn - значення кореня з нестачею та надлишком. Припустимо, що х0=1; х0=2;
Обрахунки проводимо в таблиці:

Відповідь: x2≈1,463.

3. x3∈[2,3];
f(2)<2;
f(2)>0;
f ``(x)>0 при 2≤x≤2.
Для обрахунку використаємо формули

Обрахунки робимо в таблиці, зазначивши що:

Відповідь: x3≈2,473.

 Варіанти завдань до лабораторної роботи 9
До списку лабораторных робіт


Лабораторна робота №9 : Варіанти

Лабораторна робота №9 : Розв'язування нелінійних рівнянь комбінованим методом хорд та дотичних

Завдання: Розв'язати рівняння третього степеня комбінованим методом хорд та дотичних, обрахувавши корені з точністью до 0,001.

Варіант 1

Варіант 2

Варіант 3

Варіант 4

Варіант 5

Варіант 6

Варіант 7

Варіант 8

Варіант 9

Варіант 10

Варіант 11

Варіант 12

Варіант 13

Варіант 14

Варіант 15

Варіант 16

Варіант 17

Варіант 18

Варіант 19

Варіант 20

Варіант 21

Варіант 22

Варіант 23

Варіант 24

Варіант 25

Варіант 26

Варіант 27

Варіант 28

Варіант 29

Варіант 30

 До лабораторної роботи 9
До списку лабораторних робіт


Лабораторна робота №10 : Обчислення визначених інтегралів за формулами прямокутників

Завдання 1: Обрахувати інтеграл за формулами правих та лівих прямокутників при n=10, оцінюючи точність за допомогою порівняння результатів.

Для проведення розрахунків ха формулами правих та лівих прямокутників при n=10 розіб'ємо відрізок інтегрування на 10 частин з кроком
Складемо таблицю значень підінтегральної функції в точках поділу відрізку:

В таблиці пораховані сумми
Знайдемо наближені значення інтеграла. За формулою лівих прямокутників. Одержимо

За формулою правих прямокутників знаходимо

Значення відрізняються лише тисячними, тому за остаточний результат будемо вважати середнє арифметичне між ними

Відповідь: I=0,212

Завдання 2: Обчислити інтеграл за формулою середніх прямокутників використовуючи для оцінки точності подвійний прорахунок при n1=8 та n2=10.

Для розв'язку використаємо формулу середніх прямокутників:

Обрахунки проводимо два рази для n1=8 та n2=10 відповідно при h1=(b-a)/n1=(1,2-0,4)/8=0,1 та h2=(b-a)/n2=(1,2-0,4)/10=0,08. Результати обчислень запишемо в таблиці І та ІІ.
Таблиця І

Таблиця ІІ

Знайдемо наближені значення інтегралу

Знайдені значення відрязняються десятими долями, однак друге значення більш точне, тому приймемо І≈0,4358.
Відповідь:І≈0,4358.
 Варіанти завдань до лабораторної роботи 10
До списку лабораторных робіт


Лабораторна робота №10 : Варіанти

Лабораторна робота №10 : Обчислення визначених інтегралів за формулами прямокутників

Завдання 1: Обчислити інтеграл за формулами правих та лівих прямокутників при n=10, оцінюючи точність за допомогою порівняння результатів.

Завдання 2: Обчислити інтеграл за формулою середніх прямокутників використовуючи для оцінки точності подвійний прорахунок при n1=8 та n2=10.

Варіант 1

1)
2)

Варіант 2

1)
2)

Варіант 3

1)
2)

Варіант 4

1)
2)

Варіант 5

1)
2)

Варіант 6

1)
2)

Варіант 7

1)
2)

Варіант 8

1)
2)

Варіант 9

1)
2)

Варіант 10

1)
2)

Варіант 11

1)
2)

Варіант 12

1)
2)

Варіант 13

1)
2)

Варіант 14

1)
2)

Варіант 15

1)
2)

Варіант 16

1)
2)

Варіант 17

1)
2)

Варіант 18

1)
2)

Варіант 19

1)
2)

Варіант 20

1)
2)

Варіант 21

1)
2)

Варіант 22

1)
2)

Варіант 23

1)
2)

Варіант 24

1)
2)

Варіант 25

1)
2)

Варіант 26

1)
2)

Варіант 27

1)
2)

Варіант 28

1)
2)

Варіант 29

1)
2)

Варіант 30

1)
2)
До лабораторної роботи 10
До списку лабораторних робіт


Лабораторна робота №11 : Варіанти

Лабораторна робота №11 : Обчислення визначених інтегралів за формулою трапецій та Сімпсона

Завдання 1: Обчислити інтеграл за формулою трапецій при n=20

Обчислення інтегралу проводимо за формулою

де h=(b-a)/n=0,6/20=0,003; [image] xi=0,7+ih (i=0,1,2,.., 20).
Обчислення проводимо в таблиці
;
Таким чином,
;
Відповідь: І≈0,404.

Завдання 2: Обчислити інтеграл за формулою Сімпсона при n=8

Оскільки за умовою n=8,то h=(b-a)/n=(1,6-1,2)/8=0,05;
Формула для обчислень має вигляд

Обчислення значень функції, а також додавання значень функції, що мають однакові коефіцієнти в формулі, робимо в таблиці
;
;
Відповідь:І≈0,88278.
 Варіанти завдань до лабораторної роботи 11
До списку лабораторных робіт


Лабораторна робота №11 : Варіанти

Лабораторна робота №11 : Обчислення визначених інтегралів за формулою трапецій та Сімпсона

Завдання 1: Обчислити інтеграл за формулою трапецій при n=20

Завдання 2: Обчислити інтеграл за формулою Сімпсона при n=8

Варіант 1

1)
2)

Варіант 2

1)
2)

Варіант 3

1)
2)

Варіант 4

1)
2)

Варіант 5

1)
2)

Варіант 6

1)
2)

Варіант 7

1)
2)

Варіант 8

1)
2)

Варіант 9

1)
2)

Варіант 10

1)
2)

Варіант 11

1)
2)

Варіант 12

1)
2)

Варіант 13

1)
2)

Варіант 14

1)
2)

Варіант 15

1)
2)

Варіант 16

1)
2)

Варіант 17

1)
2)

Варіант 18

1)
2)

Варіант 19

1)
2)

Варіант 20

1)
2)

Варіант 21

1)
2)

Варіант 22

1)
2)

Варіант 23

1)
2)

Варіант 24

1)
2)

Варіант 25

1)
2)

Варіант 26

1)
2)

Варіант 27

1)
2)

Варіант 28

1)
2)

Варіант 29

1)
2)

Варіант 30

1)
2)
До лабораторної роботи 11
До списку лабораторних робіт